การโหลด kv ผ่าน Subversion

ผมต้องการศึกษา KV

จึงอ่านบทความของ ดร.ธวัชชัย แล้วลองทำตามดู

แต่ติดตรงขั้นตอนการโหลดsource kv โดยผ่าน Subversion

ผมไม่สามารถโหลดได้จาก svn://svn.usablelabs.com/kms/kv/trunk ครับ

ผมจึงไปดูที่เว็บของ knowledgevolution ในหน้า browse source มี error ขึ้น จากจุดนี้ผมจะสามารถโหลด source ของ kv ได้จากที่ไหนอีกหรือครับ

คำตอบ
ตอนนี้ subversion server เราอยู่ที่ u5.usablelabs.com ครับ ให้ใช้คำสั่งต่อไปนี้แทนครับ

svn co svn://u5.usablelabs.com/kv/trunk kv

ผมย้ายเครื่องแล้วแต่ไม่ได้มีเวลาแก้เอกสารครับ ต้องขอโทษด้วยครับ
poontie

ขอบคุณมากครับ

ตอนนี้ผมโหลด source มาแล้วและแก้ไฟล์ database.yml

รวมทั้งรัน rake migrate ผ่านแล้ว

แต่ผมไม่สามารถรัน ruby script/server ใน kv ได้

=> Booting WEBrick... C:/wamp/ruby/lib/ruby/gems/1.8/gems/activerecord-1.15.3/lib/active_record/connec tion_adapters/abstract/connection_specification.rb:204:in `establish_connection' : development database is not configured (ActiveRecord::AdapterNotSpecified) from C:/wamp/ruby/lib/ruby/gems/1.8/gems/activerecord-1.15.3/lib/active_ record/connection_adapters/abstract/connection_specification.rb:195:in `establis h_connection' from C:/wamp/ruby/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/initializer.rb: 229:in `initialize_database' from C:/wamp/ruby/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/initializer.rb: 88:in `process' from C:/wamp/ruby/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/initializer.rb: 43:in `send' from C:/wamp/ruby/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/initializer.rb: 43:in `run' from ./script/../config/../config/environment.rb:10 from C:/wamp/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:i n `gem_original_require' from C:/wamp/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:i n `require' ... 9 levels... from C:/wamp/ruby/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/commands/server .rb:39 from C:/wamp/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:i n `gem_original_require' from C:/wamp/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:i n `require' from script/server:3

ปล.ในโฟลเดอร์ public ไม่มีไฟล์ index อยู่

ตรงนี้เป็นปกติของ source kv รึเปล่าครับ

ดร. ธวัชชัย ปิยะวัฒน์

อาจลง gems ที่เราต้องการไม่ครบครับ ดูเหมือนจะขาด mysql connector แต่ปกติควรจะมากับ rails แล้วนะครับ

ต้องขอเรียนว่าในการพัฒนานั้น ผมไม่ได้ทดลองกับ Windows เลยครับ อาจมีปัญหาที่ผมไม่ทราบครับ

poontie

ขอบคุณครับ

ตอนนี้ผมลองลงกับ linux แล้วครับ
และลองทำตามขั้นตอนใน
http://rd.cc.psu.ac.th/content/view/98/48

ตอนนี้ผมมีข้อสงสัย 2 ข้อครับ
1. ผมโหลด gem rails ด้วยคำสั่ง
gem install rails --include-dependencies
แต่ก็ยังเกิดปัญหาเดิมขึ้น
-ถ้าผมจะโหลด gem mysql connector แยกมาเองจะโหลดจากคำสั่งอะไรครับ

2. ใน source ของ kv ที่โหลดมาจาก svn://u5.usablelabs.com/kv/trunk
ผมสังเกตุดูว่าในโฟลเดอร์ public ไม่มีไฟล์ index.html อยู่ซึ่ง
-ผมสงสัยว่า source kv โดยปกติจะมีไฟล์ index.html อยู่ในโฟลเดอร์ public หรือไม่ครับ

ดร. ธวัชชัย ปิยะวัฒน์

1. ทดลอง gem install mysql ดูนะครับ

2. จะไม่มี index.html ครับ

poontie

ขอบคุณครับ อ.ธวัชชัย
ตอนนี้ผมเปิดหน้าแรกของ kv ได้แล้วครับ

แต่ปัญหายังไม่จบเพราะเมื่อจะ register ในขั้นตอนที่จะต้องกรอกรหัสที่ได้มาจากรูป เมื่อกด submit ลงไป kv ก็สั่ง process อยู่อย่างนั้น ไม่ไปขึ้นหน้าอื่น

ตรงนี้ผมควรแก้ไขตรงจุดไหนดีครับ 

ดร. ธวัชชัย ปิยะวัฒน์

ผมแนะนำให้ส่งคำถามนี้มาที่ http://groups.google.com/group/kv-thai ดีกว่าครับ สมาชิกจะได้ช่วยให้คำแนะนำได้และคำแนะนำนั้นจะได้สืบค้นได้ต่อไปครับ